NAM-1975

Discussion of playback questions / problems. Any recording where people have playback problems should appear here.

Moderator: Chad

User avatar
mahlemiut
Editor
Posts: 4122
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand
Contact:

NAM-1975

Post by mahlemiut » Sun Mar 31, 2002 11:47 pm

http://marp.retrogames.com/inp/ddr_nam1 ... mame57.zip

I can't play this one back past stage 2. I've tried both DOS and Win32 versions of MAME 0.57, with and without sound.

Anyone else managed to play this one back at all?
- Barry Rodewald
MARP Assistant Web Maintainer
Image

User avatar
Kale
MARP Seer
MARP Seer
Posts: 627
Joined: Fri Mar 08, 2002 5:53 pm

Post by Kale » Mon Apr 01, 2002 5:20 pm

To me it loses sync at the 2nd boss,without sound,no autoframeskip and dmame .57.

User avatar
essekappa
Button Slapper
Button Slapper
Posts: 11
Joined: Sun Mar 10, 2002 4:25 pm

Post by essekappa » Mon Apr 01, 2002 9:39 pm

I've used this command line: dmame.exe nam1975 -soundcard1 -noscanlines -joy 8button -record nam1975 (maybe scanlines are the clue??)
Anno 79 dell'era spaziale........

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Post by Chad » Tue Apr 02, 2002 2:23 am

this smells of an oplfm issue. ddr what are the values in your mame.cfg for these three settings (mine are)

ym2203opl = yes
ym3812opl = no
oplfm = yes

I've modified these settings and am getting diferent scores for this game changing these settings (8 possible combinations) using noscanlines and dosmame 57. I've gotten 165, 201, 205k playbacks, no where near 800k yet.
-skito

User avatar
mahlemiut
Editor
Posts: 4122
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand
Contact:

Post by mahlemiut » Tue Apr 02, 2002 2:47 am

I just don't get how oplfm settings would affect it when Neo Geo doesn't use either YM2203, or YM3812/YM3526.

Anyway, I tryed it with -joy 8button, despite not having a joystick/joypad connected to this PC. It played back to 330k. So still no joy. I have always had scanlines disabled.
- Barry Rodewald
MARP Assistant Web Maintainer
Image

User avatar
BBH
Editor
Posts: 1564
Joined: Wed Feb 06, 2002 7:06 am
Location: Portland, Oregon
Contact:

Post by BBH » Tue Apr 02, 2002 7:33 am

well, it looks like my first place score, recorded with m35b4, doesn't playback either... :oops: no wonder it was unconfirmed for three years. I could have sworn I played it back successfully before, but it doesn't work now.

So I think the issue now is, perhaps playback only works in certain versions of MAME? I was going to suggest recording on mame34 (where the short name is called nam_1975 instead of nam1975), since there are some Neo-Geo recordings that only work there. But there is a certain issue with this version, in some areas there is heavy in-game slowdown (which is definitely not normal, seeing how the speed doesn't change like that in other versions and I can personally verify it since I own the MVS cart). This would give people recording with this version a bit of an edge, but if it doesn't work on any other versions of MAME we may have no choice. :(

And retrogames.com currently isn't working so I can't check all the NAM-1975 scores to see if there are any that are confirmed to work with a certain version. I'd also like to point out that when I tried to play back mine on m35b4, I think what happened was that for some reason it didn't trigger the random "between-level" fights (now I think these are more stupid than ever). I say this because it showed me throwing a bunch of greandes at empty space on Stage 3, when I should be fighting the "between-boss" thingy.

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

alpham2

Post by Chad » Tue Apr 02, 2002 11:54 am

the reason i thought it smelled like a opl issue is that Alpha Mission II (alpham2) had an opl issue (and i thought that was a neo geo game but maybe it's not, can't remember) At any rate, using different opl settings got to playback with different scores for nam1975, this of course doesn't mean the game doesn't have random calls during playback....
-skito

User avatar
essekappa
Button Slapper
Button Slapper
Posts: 11
Joined: Sun Mar 10, 2002 4:25 pm

Post by essekappa » Tue Apr 02, 2002 11:10 pm

I don't think it makes any difference (IMHO BBH's right: nam may play back only on certain version of mame) but here is what I found on mame.cfg

ym3812opl = yes
oplfm = no
ym2203opl = no
Anno 79 dell'era spaziale........

User avatar
essekappa
Button Slapper
Button Slapper
Posts: 11
Joined: Sun Mar 10, 2002 4:25 pm

Post by essekappa » Tue Apr 02, 2002 11:16 pm

EHM, I was nearly forgetting that: I did see BBH complete inp few weeks ago (892,100 pts) but I don't know if I can "confirm" scores as others do (I don't have any speed checker or whatever)
Anno 79 dell'era spaziale........

User avatar
BBH
Editor
Posts: 1564
Joined: Wed Feb 06, 2002 7:06 am
Location: Portland, Oregon
Contact:

Post by BBH » Wed Apr 03, 2002 12:05 am

essekappa wrote:EHM, I was nearly forgetting that: I did see BBH complete inp few weeks ago (892,100 pts) but I don't know if I can "confirm" scores as others do (I don't have any speed checker or whatever)
Okay, so my recording did playback correctly for you? That's a relief... perhaps it only works with the OPL options that you have in your mame.cfg, I'll have to check mine when I get home from work and try to play it back with those options to see if it's fine here too (I probably changed them at some point, it has been three years...)

Also, you don't need a speed-checking utility to be able to confirm scores, you just have to verify that the score plays back to the correct score (without cheats that can be spotted in gameplay, such as Ghosts n Goblins stage 3 leeching). Ask Gameboy9 to be added as a confirmer.

User avatar
BBH
Editor
Posts: 1564
Joined: Wed Feb 06, 2002 7:06 am
Location: Portland, Oregon
Contact:

Post by BBH » Tue Apr 09, 2002 9:34 am

I think the main thing that is breaking NAM-1975 recordings are those retarded "extra" boss battles that occur randomly between levels... there seems to be no way to force them to occur, which is insanely stupid because you have to rely on them happening if you want a higher score. Anyway, since my 961,100 score doesn't seem to be playing back for anyone else, I'm still trying to find a way to get this damn game to play back. I've just tried recording a game on mame36 with sound off. It played back correctly with sound off, broke on Stage 2 with sound on (for some reason I actually died on the Stage 2 boss?? Barry told me this happened on the 961k inp too... strange). Since this score is lower, I'm just going to put it up here for now since this recording was mainly intended as a test (and besides, I'm not happy about the stupid deaths that occured on Stages 3 and 5). Please tell me if this works correctly with sound off on DOS MAME 0.36 Final, it did for me but I want to be sure it will work for others.

http://bbh.marpirc.net/bbh_nam1975_891700_mame36.zip

I only got the random boss battle after Stage 3, no random battles on Stages 1, 2, and 4.... meaning if you see one happen, that's not correct and it's not going to work. I really hope turning sound off is the key...

User avatar
BBH
Editor
Posts: 1564
Joined: Wed Feb 06, 2002 7:06 am
Location: Portland, Oregon
Contact:

Post by BBH » Thu Apr 11, 2002 7:52 am

BBH wrote:Please tell me if this works correctly with sound off on DOS MAME 0.36 Final, it did for me but I want to be sure it will work for others.

http://bbh.marpirc.net/bbh_nam1975_891700_mame36.zip
Anyone? Anyone? Bueller?

I'd really like to replace my current recording on MARP with one that has some reliability in playing back, but I won't know if this actually works right until somebody tells me...

User avatar
Kale
MARP Seer
MARP Seer
Posts: 627
Joined: Fri Mar 08, 2002 5:53 pm

Post by Kale » Thu Apr 11, 2002 11:59 am

It's because of that fuckin' RTC that Nam1975 doesn't playback...

User avatar
BBH
Editor
Posts: 1564
Joined: Wed Feb 06, 2002 7:06 am
Location: Portland, Oregon
Contact:

Post by BBH » Thu Apr 11, 2002 4:50 pm

Kale wrote:It's because of that fuckin' RTC that Nam1975 doesn't playback...
That's not exactly the specific answer that I was looking for.

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Post by Chad » Fri Apr 12, 2002 3:05 am

BBH wrote:
BBH wrote:Please tell me if this works correctly with sound off on DOS MAME 0.36 Final, it did for me but I want to be sure it will work for others.

http://bbh.marpirc.net/bbh_nam1975_891700_mame36.zip
Anyone? Anyone? Bueller?

I'd really like to replace my current recording on MARP with one that has some reliability in playing back, but I won't know if this actually works right until somebody tells me...
this the response you're looking for?

891700 confirmed, played it back twice one with fs0 no throttling, another time iwth fs0 with throttling. i'll bet the earlier version of mame took a NON RTC seed or a seed based on user inp (so when it playsback it can regereate the dangseed. huuh huh, he sayd seeed, huh huh.)

kale, can you mail me your patch you sent to mamedev? i'll bet if it is forces all neogeo mame games to use a constant seed they won't allow it, unless it's connected to a user option to turn off or on.
-skito

Post Reply