The mame63 Bug

Discussion of playback questions / problems. Any recording where people have playback problems should appear here.

Moderator: Chad

Post Reply
User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Games that should be recorded with mame62 or less

Post by Chad » Sun Jun 08, 2003 7:31 pm

Some wierd bug in mame was introduced in mame63 that is allowing some to playback and others not to playback recordings even when the same os/mame/settings are used. BELOW: is the known danger list to use mame62 ONLY with (http://alphamame.marpirc.net/alphamame-062-3.zip) untill we can find out what's wrong. Many Midway games are affected, though not listed here yet. And Darius potentially has this problem.

Depth Charge http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
Angel Kids http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
Emeralda http://marp.retrogames.com/index.cgi?mo ... rt&tourn=0
BatRider http://marp.retrogames.com/index.cgi?mo ... rt&tourn=0
stocker http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
tron http://marp.retrogames.com/index.cgi?mo ... rt&tourn=0
tapper crew http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
VblockBreak (and clones not listed) http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
Mortal Komat and gang http://marp.retrogames.com/index.cgi?mo ... rt&tourn=0
metalclash http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
snakepit http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
cloak http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
raident http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
zwackery http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
paradise http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0
and the nba gang http://marp.retrogames.com/index.cgi?mo ... 00&tourn=0

more description of this bug:

these games are where there is a mame bug (introduced in mame63 and beyond) where it divides the pc population into two groupos (A) and (B). If you have a machine in set (A) and make an inp recording, only the people with machines in set (A) can playback your score. Same goes for set (B). And any recording made on a set (A) machine can't be playedback on a set (B) machine. Here's a list of players and hardware in each set.

------------------------
Set A : Celery Set

Chad = AMD1800mp TyanTiger 1Gram nvgf3 XPpro+98se LocalTime
Buttermaker's = Celeron
zlk = P4-2.5 ASUSP4T533-C 1Gram NvGf3 XP SP1
barry = Athlon950 128Mram TNT2 M64 ME+Linux7.2
TJT = P4-2.4 RhinoP4X266AR-AE4 256M*2ram NvGf4MX440 SB128 98SE
Kelly = Duron650 392Horses W2Kpro SP3
joeyL = 1800xp
dbh = win2000
NotMan =
LordGaz =


------------------------
Set B : P4 Set

Buttermaker's = P4
BBH = P4 HewletcraP eXtracraPy
QtQuazar =
kfx = athlon 1.4 win98se
Abbe =
Zteuer =

------------------------
Last edited by Chad on Tue Sep 02, 2003 12:05 pm, edited 22 times in total.
-skito

Buttermaker
MARP Seer
MARP Seer
Posts: 788
Joined: Sun May 19, 2002 9:06 am

Post by Buttermaker » Sat Jul 12, 2003 5:49 pm

Here's a list of players and hardware in each set.
Something to keep in mind though from my tests:
Luja's pairs: Desyncs right at the start on the P4, works on the Celery. This is pretty strange because it was the other way around with Luja's zwackery which worked on the P4 but not on the Celery.

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Post by Chad » Sat Jul 12, 2003 7:23 pm

Buttermaker wrote:
Here's a list of players and hardware in each set.
Something to keep in mind though from my tests:
Luja's pairs: Desyncs right at the start on the P4, works on the Celery. This is pretty strange because it was the other way around with Luja's zwackery which worked on the P4 but not on the Celery.
Yeah this must mean it's something in the game play or recording that dictates the set, if it can be reversed, maybe.
-skito

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Post by Chad » Sun Aug 03, 2003 9:43 pm

major havoc and recruits http://marp.retrogames.com/index.cgi?mo ... rt&tourn=0

may need the -noleds or -leds option to playback correctly.
-skito

User avatar
Zteuer
Button Masher
Button Masher
Posts: 37
Joined: Sun Sep 08, 2002 9:34 am
Location: Norway
Contact:

Post by Zteuer » Tue Sep 02, 2003 12:58 pm

I should be in the Celeron list. I have 1.3 GHz and I use XP.

gamerya
Button Masher
Button Masher
Posts: 51
Joined: Sat Sep 13, 2003 3:14 pm

Post by gamerya » Tue Oct 21, 2003 9:20 pm

Zteuer wrote:I should be in the Celeron list. I have 1.3 GHz and I use XP.
Is it just me...or are you completely random?

Buttermaker
MARP Seer
MARP Seer
Posts: 788
Joined: Sun May 19, 2002 9:06 am

Post by Buttermaker » Tue Oct 21, 2003 9:28 pm

gamerya wrote:Is it just me...or are you completely random?
Read this thread carefully.

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Post by Chad » Tue Oct 21, 2003 10:11 pm

The bug here might be solved by using mame 75 or later games so i'm spliting this from the sticky topic, of course i split it (again) to the wrong forum, seymore can you move it back to Playabakability??? thanks.
-skito

Buttermaker
MARP Seer
MARP Seer
Posts: 788
Joined: Sun May 19, 2002 9:06 am

Post by Buttermaker » Sat Nov 22, 2003 11:02 am

Enduro Racer has the .63 bug. You can test this by watching zlk's and SJK's endurob2 inps. One of the two will work, the other won't. Wolfmame .71u2 for playing back SJK's inp is here: http://mahlemiut.marpirc.net/wolfmameplus-071u2-2.zip

http://marp.retrogames.com/index.cgi?mo ... lines=9999

I wonder if Haze is reading this.

Post Reply