xsleena solarwar - Xain'd Sleena

Discussion of playback questions / problems. Any recording where people have playback problems should appear here.

Moderator: Chad

User avatar
destructor
MARPaholic
MARPaholic
Posts: 1969
Joined: Fri Sep 20, 2002 9:38 am
Location: Poland

xsleena solarwar - Xain'd Sleena

Post by destructor » Tue Nov 11, 2008 7:41 am


Abbe
MARP Knight
MARP Knight
Posts: 203
Joined: Wed Mar 06, 2002 12:32 pm
Location: Sweden
Contact:

Re: xsleena solarwar - Xain'd Sleena

Post by Abbe » Tue Nov 11, 2008 8:20 am

Same thing for me, even after some playing around with different options.
-Abbe

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Re: xsleena solarwar - Xain'd Sleena

Post by Chad » Wed Nov 12, 2008 2:49 am

both are now zeroed due to the three strikes rule. Can't figure this out, only thing i know is dvl's older wolf79 recording playsback fine ONLY with sound and does not with out.

http://marp.retrogames.com/inp/b/6/0/dv ... wolf79.zip
-skito

User avatar
destructor
MARPaholic
MARPaholic
Posts: 1969
Joined: Fri Sep 20, 2002 9:38 am
Location: Poland

Re: xsleena solarwar - Xain'd Sleena

Post by destructor » Wed Nov 12, 2008 2:58 am

wolf79 recording playbacks fine (i tried with sound only).

User avatar
DaviL
MARP Knight
MARP Knight
Posts: 202
Joined: Sat Oct 12, 2002 7:16 pm
Location: Italy

Re: xsleena solarwar - Xain'd Sleena

Post by DaviL » Wed Nov 12, 2008 10:05 am

was ok on my pc. can t test now for wolf version i m not at home.
try nosound option and will be ok.

User avatar
destructor
MARPaholic
MARPaholic
Posts: 1969
Joined: Fri Sep 20, 2002 9:38 am
Location: Poland

Re: xsleena solarwar - Xain'd Sleena

Post by destructor » Wed Nov 12, 2008 11:42 am

The same with -nosound.

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Re: xsleena solarwar - Xain'd Sleena

Post by Chad » Wed Nov 12, 2008 11:51 am

yeah -nosound i also had tried with no success...
-skito

User avatar
mahlemiut
Editor
Posts: 4133
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand
Contact:

Re: xsleena solarwar - Xain'd Sleena

Post by mahlemiut » Thu Nov 27, 2008 6:16 pm

I've figured it out! Looks like DIP switches are no longer stored in the INP, or aren't being read from the INP.

Xain'd Sleena displays the extend settings when you insert a coin. I think you'll find that it will match whatever your settings are using. So if you're using a playback script, it'll always use the default 20k/70k/70k. To play it back correctly, you have to set the DIP switches to match what was used when recording, which should be 30k/80k.

Tested with Des' current INP - http://marp.retrogames.com/inp/a/0/6/dt ... olf128.zip - although I still have to watch it in its entirety. Which I'll do now. :)

Update: Playback is fine with DIPs set to 30k/80k.
- Barry Rodewald
MARP Assistant Web Maintainer
Image

User avatar
Chad
Tournament Coordinator
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Re: xsleena solarwar - Xain'd Sleena

Post by Chad » Thu Nov 27, 2008 7:20 pm

OMG, amazing find! you'd have thunk that with all those crap bits per frame they could include the dipswitches too. I guess it's time for another inp overhaul. If you are going to add a patch to add the dips back in, 8 bytes of reserved space in the inp header for a crc would be nice for mess software :)

I played back dvls record just fine with 30k/80k (i'm assuming 30/80 fits under the 20k/80k rule), when it finishes i will reconstitute.

http://marp.retrogames.com/inp/6/0/e/dv ... olf125.zip
-skito

User avatar
Phil Lamat
Regulation Coordinator
Posts: 2014
Joined: Wed Mar 06, 2002 9:19 am

Re: xsleena solarwar - Xain'd Sleena

Post by Phil Lamat » Fri Nov 28, 2008 5:48 am

mahlemiut wrote: Looks like DIP switches are no longer stored in the INP
:evil: :twisted:

User avatar
destructor
MARPaholic
MARPaholic
Posts: 1969
Joined: Fri Sep 20, 2002 9:38 am
Location: Poland

Re: xsleena solarwar - Xain'd Sleena

Post by destructor » Fri Nov 28, 2008 6:21 am

It is not good. If player by mistake change something in settings, we can have problems with playback inps :(

User avatar
mahlemiut
Editor
Posts: 4133
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand
Contact:

Re: xsleena solarwar - Xain'd Sleena

Post by mahlemiut » Thu Dec 04, 2008 5:40 pm

Bug has now been fixed, should be working in 0.128u5 (when released). Aaron has also added compression to INPs as well. Might make putting INPs in zips interesting... we'll see when we get there :)
- Barry Rodewald
MARP Assistant Web Maintainer
Image

User avatar
sawys
MARPaltunnel Wrists
MARPaltunnel Wrists
Posts: 584
Joined: Wed Apr 14, 2004 10:13 am
Location: France

Re: xsleena solarwar - Xain'd Sleena

Post by sawys » Sat Dec 06, 2008 4:02 am

The bug you're talking about was not a bug for the players who played with default settings !!

It permitted to be sure that default settings were used to play a game...

I know that in marp you can change settings to harder or easier if tg allows but personally for mamescore it was a good bug ^^

Now that it has been fixed, it would be good to see the dipswitches used by the players during a recording like wolf 78 did.
Sawys is Sébastien GIRAUD, admin of MAMESCORE, member of MARP, TWIN GALAXIES, RETRO UPRISING and ex-member of JVRM :-D

User avatar
mahlemiut
Editor
Posts: 4133
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand
Contact:

Re: xsleena solarwar - Xain'd Sleena

Post by mahlemiut » Sat Dec 06, 2008 7:03 am

sawys wrote:The bug you're talking about was not a bug for the players who played with default settings !!
Which is most people, and is probably why it took 6 months to find.
- Barry Rodewald
MARP Assistant Web Maintainer
Image

User avatar
DaviL
MARP Knight
MARP Knight
Posts: 202
Joined: Sat Oct 12, 2002 7:16 pm
Location: Italy

Re: xsleena solarwar - Xain'd Sleena

Post by DaviL » Thu Jan 08, 2009 3:12 pm

http://marp.retrogames.com/r/solarwar
http://marp.retrogames.com/inp/f/0/a/dv ... olf125.zip

Hi, this inp is OK but was Zeroed and not restored
Dipswitch must be set to 20k 80K like Xsleena

Post Reply